My phone is an LG Stylo 3 Android 7.0 and still not compatible. I was able to preregister and according to Google Play only 5.0 and higher is required. So, why is my phone not compatible?

Answered question