After clinging to a flip phone for years I finally upgraded to a smart phone once my provider said they would no longer support updates for it.  I was excited to hear there would be a Harry Potter traveling game but then got confused when it said it wasnt available in my country (USA resident).  And today I tried to see if i could get it and said not compatible.  I have an LG Rebel 4 LTE/LGE LML212VL with Android 8.1.0 and it runs PokemonGO just fine, I dont see why Wizards Unite would be incompatible.  What gives?

Edited question