Sony xperia 3 has been confirmed to work, and mine has a high enough android version and is a newer model of the phone, so shouldn’t it be supported?

Thanks for any help i get

Edited comment

To clarify android 7.1.1 and Sony Z5 Compact