My phone which came out a few years ago the Samsung galaxy j3 emerge, does not show up in either list nor in the play store app so I would like to know if my phone will be/could be compatable with the app

Posted new comment

I hope so. It says it requires at least 5.0 and I checked and mine says it’s a 6.0.1