Hello i want to ask what type of phones does the game gonna need to run? Because i try to pre regester and its said that my phone is not complete with the game. I also saw many people who have the same problem.

Posted new comment

Hey Cyber, which phone do you have? And which phones do other people have (if you know by any chance)?

I have xiaomi redmi 6.
Now from others i have just read comments from some post in wizards unite facebook page.

Mine is Huawei Nova 2 Lite. It says not compatible too. 😔

I have a Samsung J7 Sky Pro but I can’t get a straight answer if mine is compatiable. I was able to Pre register for Wizards Unite in the beginning but now it’s saying it’s not compatiable. What does it mean

I have a LG Stylo 4 at first I could pre-register but now it says that my device is not compatible with this “version” I don’t understand will there soon be an update later for a different version that will work?